Announcement

Collapse
No announcement yet.

Black Screen and no shutter release

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! Black Screen and no shutter release

    Anyone have any experience with this . . .

    . . . with my new E-PL1, the camera LCD goes black every once in a while. Not only can I not seeing anything to shoot, but the shutter will not fire. I am presuming this may be a sleep mode that the camera goes into where it shuts down the functionality - - - although it isn't like the camera was sitting in rest for a long period of time. This happened once in the camera store also when i was buying it. what is strange is that the Playback of images works fine as well as setting of all menu items - - - just can't take a picture or see anything to take a picture of. The only way that I have figured to restore the functionality is to turn off the camera and then turn it back on. Although on a couple of occasionsthat didn't work the first time either.
    INSTAGRAM - @rswpix

  • #2
    Re: Black Screen and no shutter release

    If it's in sleep mode it should wake up by pressing any button and shouldn't require you to turn off and on again. I've not met an Olympus camera yet that performs that way. Plus if it wakes up to go into playback, it should wake up the rest of the functions as well. Don't be surprised if you can't release the shutter to wake up the camera though. You should have to hit one of the control buttons instead (I usually use the Info button).

    Maybe your camera is going to sleep, but is not waking up properly? Something like what a venerable old computer would do, lol.

    I don't have the E-PL1, but my E-P1 would never do this. I think your camera needs to be returned or serviced, personally.
    Olympus E-3 | Olympus E-PL2 PEN | Olympus E-PM1 PEN | Zuiko ED 50-200mm f/2.8-3.5 SWD | Zuiko 14-54mm f/2.8-3.5 | Vivitar 100mm f/2.8 Macro | Carl Zeiss Sonnar 135mm f/2.8 | Konica Hexanon 50mm f/1.4 | Konica Hexanon 85mm f/1.8 | G.Zuiko 50mm f/1.4 | Zuiko 35mm f/3.5 Macro | Zuiko 25mm f/2.8 | KMZ Jupiter-3 50mm f/1.5 | E.Zuiko 200mm f/4 | Zuiko 75-150mm f/4 | Olympus EC-14 teleconverter | VF-2 and VF-3 Viewfinders | EMA-1 Mic Adapter | Olympus FL-36R and FL-50R speedlights

    cyclopsphoto.ca

    Comment


    • #3
      Re: Black Screen and no shutter release

      Thanks Ned - the Info button doesn't wake it up. I have also just set Sleep to off in the MENU, and it just did it again.

      All of my Menu Settings keeps resetting to default from time to time too. Yuk.
      INSTAGRAM - @rswpix

      Comment


      • #4
        Re: Black Screen and no shutter release

        I just phoned Henrys Camera in London where I purchased the E-PL1 on Monday,

        and they are bringing a new one in for me by Friday and replacing this

        one because of the issue I described to them.

        That should let me know if it is a settings problem or camera issue for sure.

        Thanks for your help NED.
        INSTAGRAM - @rswpix

        Comment

        Working...
        X