Announcement

Collapse
No announcement yet.

Lens trouble

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! Lens trouble

    I got the Olympus E-PL1 Lat May and its been wonderful. But since last week when I zoom in the the is a message saying "Please check the status of a lens" .
    The lens is the 14-42mm default lens that comes with the camera.
    Any helping advice is much appreciated.
    Thanks:

    Edit: I forgot to mention that the lens does work from 14mm to about 27mm. Once it passes that the message comes on the screen saying "please check status of a lens"...
    Last edited by Apex; 25th February 2013, 10:53 AM.

  • #2
    Re: Lens trouble

    Hi

    I think the first thing to do is check and clean the contacts on both the lens and the camera.

    Good luck
    All the best

    Andy

    E1,E5,E420,OM1(N),14-54,12-60SWD,7-14,50-200,50mm F2 macro,25mm pancake,EC14,Sigma 50-500,OM50mm(F1.8),OM28mm(f2.8),FL36,HLD4,HLD2,Epson P3000,Manfrotto 680b monopod,crap tripod,various filters/CF cards.


    http://www.flickr.com/photos/andypeter/

    Comment


    • #3
      Re: Lens trouble

      andym, Thanks for the advice but still no good.

      Comment


      • #4
        Re: Lens trouble

        Shame,lot of problems like this are often caused by dirty contacts.

        Sounds like a return to service if it's still under warranty.
        All the best

        Andy

        E1,E5,E420,OM1(N),14-54,12-60SWD,7-14,50-200,50mm F2 macro,25mm pancake,EC14,Sigma 50-500,OM50mm(F1.8),OM28mm(f2.8),FL36,HLD4,HLD2,Epson P3000,Manfrotto 680b monopod,crap tripod,various filters/CF cards.


        http://www.flickr.com/photos/andypeter/

        Comment


        • #5
          Re: Lens trouble

          It's a lens problem. . . . I've had that happen with 2 lenses now. . . . . Call and find out how much it would be to fix the lens. Then check what a used one would cost. . . . I just upgraded to a better lens because the cost to fix was so high.. . . . . .

          Comment


          • #6
            Re: Lens trouble

            Damn.. I was hoping I wont have to buy a new lens. If you don't mind me asking, which one did you buy to replace the malfunctioned one?
            Thanks for the help

            Comment


            • #7
              Re: Lens trouble

              I upgraded to the Oly 14-42 II lens. . . . NOT the II R just the II. . . KEH had it used for around a $100 usd. . . . . . Shipping was under $10. . . . The II R is around $200 used, all though I hear of deals for new ones at around the same price, now a days. . .
              The other lens that I had problems with was the Sigma 19mm 2.8. I went through two of those before I found one that would work correctly. . . . .
              I find that buying used with my budget works fine. . . . As long as I stick with well know sellers. . . . .

              Comment

              Working...
              X