Announcement

Collapse
No announcement yet.

E-520 AF failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! E-520 AF failure

    Hello to all.

    Today I've experienced a strange failure in my E-520's Af system.
    The camera stopped focusing in S-AF and S-AF + MF, but is focusing perfectly in Live view (All modes) and C-AF and C-AF + MF.

    I've tried all the usual procedures (reset the camera, turn off/turn on, battery out) and everything stays the same (Af ok in live view and C-Af, and AF dead in S-Af).

    Has anyone experience something like this?

    Best regards,
    Rogerioi

  • #2
    Re: E-520 AF failure

    Originally posted by rogerioi View Post
    Hello to all.

    Today I've experienced a strange failure in my E-520's Af system.
    The camera stopped focusing in S-AF and S-AF + MF, but is focusing perfectly in Live view (All modes) and C-AF and C-AF + MF.

    I've tried all the usual procedures (reset the camera, turn off/turn on, battery out) and everything stays the same (Af ok in live view and C-Af, and AF dead in S-Af).

    Has anyone experience something like this?

    Best regards,
    Rogerioi
    There could be dust on the phase detect AF sensor lens, which is below the mirror in the mirror box. In live view the main image sensor determines the AF.

    Try using a blower brush (without the brush) to blow any dust out of the area directly below and behind the mirror. Be careful as the mirror is very delicate. Don't use your breath!

    Ian
    Founder/editor
    Four Thirds User (http://fourthirds-user.com)
    Digital Photography Now (http://dpnow.com)
    Olympus UK E-System User Group (http://e-group.uk.net)
    Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)
    Twitter: www.twitter.com/ian_burley
    Flickr: www.flickr.com/photos/dpnow/
    Pinterest: www.pinterest.com/ianburley/

    Comment


    • #3
      Re: E-520 AF failure

      Hi and Thank you, Ian.

      I've done it, and everything stays the same.

      But I don't believe it is something "mechanical" because de AF phase sensor works ok in C-AF and C-AF+MF.

      Perhaps if I could reload the firmware, but I can't perform an upgrade, because it is already upgraded...

      It is really odd.

      Comment


      • #4
        Re: E-520 AF failure

        Maybe check your focus modes in the first wrench menu under Lock: AEL/AFL. The default for SAF (focus on half-press of shutter) should be Mode 1. If you use back-button focus, it should be Mode 3.

        Have you tried a factory reset from the Custom Reset menu?
        Olympus E-3 | Olympus E-PL2 PEN | Olympus E-PM1 PEN | Zuiko ED 50-200mm f/2.8-3.5 SWD | Zuiko 14-54mm f/2.8-3.5 | Vivitar 100mm f/2.8 Macro | Carl Zeiss Sonnar 135mm f/2.8 | Konica Hexanon 50mm f/1.4 | Konica Hexanon 85mm f/1.8 | G.Zuiko 50mm f/1.4 | Zuiko 35mm f/3.5 Macro | Zuiko 25mm f/2.8 | KMZ Jupiter-3 50mm f/1.5 | E.Zuiko 200mm f/4 | Zuiko 75-150mm f/4 | Olympus EC-14 teleconverter | VF-2 and VF-3 Viewfinders | EMA-1 Mic Adapter | Olympus FL-36R and FL-50R speedlights

        cyclopsphoto.ca

        Comment


        • #5
          Re: E-520 AF failure

          Thank you Ned!

          You are right!
          Last night I was resetting some things in the menu and must have done something in the button setting without notice. S-AF is working Ok now.

          Best regards and many thanks to you all.

          Rogerio

          Comment


          • #6
            Re: E-520 AF failure

            Awesome! I'm glad that worked out for you... I can imagine how worried you must have been, as I've been in similar spots myself, lol.
            Olympus E-3 | Olympus E-PL2 PEN | Olympus E-PM1 PEN | Zuiko ED 50-200mm f/2.8-3.5 SWD | Zuiko 14-54mm f/2.8-3.5 | Vivitar 100mm f/2.8 Macro | Carl Zeiss Sonnar 135mm f/2.8 | Konica Hexanon 50mm f/1.4 | Konica Hexanon 85mm f/1.8 | G.Zuiko 50mm f/1.4 | Zuiko 35mm f/3.5 Macro | Zuiko 25mm f/2.8 | KMZ Jupiter-3 50mm f/1.5 | E.Zuiko 200mm f/4 | Zuiko 75-150mm f/4 | Olympus EC-14 teleconverter | VF-2 and VF-3 Viewfinders | EMA-1 Mic Adapter | Olympus FL-36R and FL-50R speedlights

            cyclopsphoto.ca

            Comment

            Working...
            X