Announcement

Collapse
No announcement yet.

E-5 will not trigger

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • E-5 will not trigger

    I have problems with my E-5.
    I was doing a time lap test with Triggertrap when the camera stopped working. The last shots that was taken is the one you see below.
    I have done some testing with a fully loaded battery and her is what I know so far:
    When I press the trigger button half way down, I thing that I can hear the camera try to focus.
    Pressing the button all the way down, there is now sound from the shutter/mirror and the screen goes completely black. The LCD display flicker.
    To turn the screen on again, I have to power off and wait approximately 10 sec. before switching on again.
    I am able to look in all the menus and I have checked the shutter count which is a little over 6000 .
    I have changed battery and used another lens without any improvements.
    When switching to Live View the screen is black. The view on the screen is like the second last on.
    As far as I can see it must be something with the mirror.
    Do anyone have an idea?

    The camera is still under warranty, it will be two years in January 2012.



    Torv@ld

  • #2
    Re: E-5 will not trigger

    How it looks like when you dismount the lens, pushing the shutter release all the way down? (any faulty parts should be easily visible during exposure)
    Can you move the mirror up by gentle push of your finger without any wobble or uneven resistance?
    Is the shutter intact? (yeah, quite stupid question, but it looks really weird from these pictures)
    Regards, Pavel.

    E-1(x2) | ZD 14-45 | ZD 14-54 | ZD 40-150 Mk.1 | ZD 70-300 | FL-50 | Velbon Sherpa 750R
    M42(Pancolar 50/1.8, Pentacon 200/4)+ M42->4/3 reduction

    Comment


    • #3
      Re: E-5 will not trigger

      Thanks for your reply Pavel.
      I did as you recomanded and moved the mirror with a cotton stick. The mirror moved up and dowen with ease. I took a photo while holding the mirror in open position and as you can see, there is something wrong. I'm not sure what I see, if it's the shutter or something els.
      I tried to set the camera in Live View because I think that this should lift the mirror, but it did not move



      I guess it has to go back to Olympus
      Torv@ld

      Comment


      • #4
        Re: E-5 will not trigger

        Uh-oh. If it is what I think it is, then one of the shutter parts somehow fell off and damaged rest of the shutter during exposures. That's BAD.
        And a real shame as these pieces should be able to work properly for 150000+ exposures.
        You are "lucky" this happened when it is still under warranty, otherwise the repair would be costly. Hopefully Oly service won't charge you for that.

        Wish you luck!
        Regards, Pavel.

        E-1(x2) | ZD 14-45 | ZD 14-54 | ZD 40-150 Mk.1 | ZD 70-300 | FL-50 | Velbon Sherpa 750R
        M42(Pancolar 50/1.8, Pentacon 200/4)+ M42->4/3 reduction

        Comment


        • #5
          Re: E-5 will not trigger

          Originally posted by T-Lama View Post
          Uh-oh. If it is what I think it is, then one of the shutter parts somehow fell off and damaged rest of the shutter during exposures. That's BAD.
          And a real shame as these pieces should be able to work properly for 150000+ exposures.
          You are "lucky" this happened when it is still under warranty, otherwise the repair would be costly. Hopefully Oly service won't charge you for that.

          Wish you luck!
          The Olympus 2-year warranty will last for 14 days more. Luckily I bought it in Norway from one of the more respected retailers. I will try to contact them today.
          Torv@ld

          Comment


          • #6
            Re: E-5 will not trigger

            Then the camera is on its way to the dealer and we will see how good the Olympuse service is.
            Torv@ld

            Comment


            • #7
              Re: E-5 will not trigger

              At last the camera is back It took about 2.5 month from the day I mailed it to the dealer. It seems like it is working OK. I hope it would last
              Torv@ld

              Comment


              • #8
                Re: E-5 will not trigger

                That seems like a long time for a repair but at least your camera was repaired and probably had a "check up" along the way, now should be good as new. Thanks for updating the thread with the final results, always nice to see what the outcome was...
                "Stef" E-620 and stuff...

                Comment

                Working...
                X