Announcement

Collapse
No announcement yet.

'check status of lens' issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 'check status of lens' issue

    Hi folks,

    some advice needed. I have looked at other threads on the 'check status of a lens' issue but i'm hoping someone has some further advice than has so far been mentioned.

    firstly i'll explain the issue: the lens works - sometimes the camera (e-pl2 with the 14-42mm kit lens) takes 4-10 pictures before the 'check status' message comes up & no further pics are possible unless you turn the camera off & on again. I've cleaned the connection points etc. so its not that & i've also tried a different lens on the e-pl2 body & that works ok. Have also updates the firmware on the camera & the lens.

    what i'd like to know is what is actually going on ? I mean, if the lens can work (as it does take photos,can be focused, zoomed etc), then i'd like to know why, after a few pics being taken, it stops working. Also, does anyone know how a lens with this kind of issue is repaired ?

    ta.

  • #2
    Re: 'check status of lens' issue

    Hi jshire,

    I've got exactly the same camera, lens and problem. And,,, we're not the only ones.

    If you try again you'll notice that the 'check the status of your lens' message is not random.
    It happens when you zoom past the 30mm point and then press the shutter to focus the image. That's when you'll get the message.
    There is no solution, other then sending it for repair to Olympus, or replacing the lens.

    Temporarily solutions are:
    -Switching the camera off and turn it back on.
    or,
    -Zoom out and press the release button of the lens. No idea why this works, but it does.

    I've sent an email to olympus today hoping that they'll fix it or replace it.
    But i doubt that, since its more than two years ago since i bought the camera.
    Otherwise i'll have to buy a new lens. Probably Panasonic

    Until then the only option is: taking pictures without zooming in.

    Hope this helps.

    Good luck.

    Comment


    • #3
      Re: 'check status of lens' issue

      ta - well, mine is more than 2 years old. I actually have a e-pl5 also & my daughter has the e-pl2 now. I guess another lens will be the solution.

      any suggestions for the panasonic ones ?

      Comment


      • #4
        Re: 'check status of lens' issue

        Well, i wasn't serious about the panasonic lens, it was a joke.
        If Olympus' customer service lets me down, i'll buy a Panasonic lens...
        -------
        It all depends on what you want i guess. I like the 14-42mm lens because it's a small lens for general purpose. That's why i'll be looking for something similar.

        Comment


        • #5
          Re: 'check status of lens' issue

          Originally posted by jshire View Post

          what i'd like to know is what is actually going on ?
          one of two things is going on

          1. the lens isn't locked open because the locking mechanism is worn, has been forced, there's debris in the mechanism or it simply isn't being lock open properly before use.
          2. the sensor telling the camera it isn't locked is faulty and is telling the camera it's not locked fully open when it is.

          given that these lenses can be got for peanuts SH from forums such as these, if it troubles you I would just get another if it's out of warantee
          E-P1, OMD E-M1, E400
          7-14/12-50/12-60/14-42/17/30(1.4)/35-100/40-150/45/50/50-200
          ec14/ec20/ex25/MMF-1, MMF-3/ RF11/FL50Rs/FL36R/SHV-1/AC-1/AC-2

          Comment


          • #6
            Re: 'check status of lens' issue

            Originally posted by rubennl View Post
            Well, i wasn't serious about the panasonic lens, it was a joke.
            If Olympus' customer service lets me down, i'll buy a Panasonic lens...
            -------
            It all depends on what you want i guess. I like the 14-42mm lens because it's a small lens for general purpose. That's why i'll be looking for something similar.

            Hi,

            Did you hear back from Olympus on this ? My EPL3 ran into this issue last weekend.. Would like to know your experience.

            Comment

            Working...
            X