Announcement

Collapse
No announcement yet.

Am I Missing Something?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Am I Missing Something?

    Hi, please forgive the rookie question but I'm stumped here. I'm shooting on a Panasonic GH4. I got the passive Canon EF Lens to Micro Four Thirds Camera Lens Turbo Adapter in order to use a Sigma 20mm f/1.8 EX Aspherical DG DF RF AF Lens (EF mount). I knew I was going to be manually focusing but totally glazed over the lack of a manual aperture adjustment on the lens. Even in manual mode I am unable to adjust it in the camera. Am I totally missing a fundamental aspect here? Thanks for any enlightenment.

  • #2
    Re: Am I Missing Something?

    If your lens doesn't have manual aperture control then you need to get an adapter that does.
    Like this:
    http://www.bhphotovideo.com/c/produc...o_4_3_mft.html

    Rob

    Comment


    • #3
      Re: Am I Missing Something?

      Thank you Rob. I didn't know those existed. I guess it will be a trade off then; losing the larger field of view afforded by the lens turbo.

      Comment


      • #4
        Re: Am I Missing Something?

        There are two versions available. One has electronic pass-through control so the camera can control the lens aperture and the significantly cheaper version is all-manual and incorporates a lens iris inside the adapter. I would expect unusual problems with the latter!

        Ian
        Founder/editor
        Four Thirds User (http://fourthirds-user.com)
        Digital Photography Now (http://dpnow.com)
        Olympus UK E-System User Group (http://e-group.uk.net)
        Olympus camera, lens, and accessory hire (http://e-group.uk.net/hire)
        Twitter: www.twitter.com/ian_burley
        Flickr: www.flickr.com/photos/dpnow/
        Pinterest: www.pinterest.com/ianburley/

        Comment

        Working...
        X