PDA

View Full Version : GH2 LCD is Dead! I think.



BB from NYC
11th March 2013, 03:10 AM
Hello all, my 9-month old GH2 LCD screen is now dead, black, no power, nothing. There were no incidents of dropping, banging, yanking or bending. It just came out of the kit bag tonight and will not work.

- Auto LVF-LCD is off.
- LCD brightness level is 2.
- Lens is seated firmly, not grazing the silver lens release button while holding.
- Pressing LVF-LCD button on back properly operates LVF but LCD no reaction, just black.

Am I missing something?
Any other ideas before I have to ship it out to repair?

Thanks...

RobertD
11th March 2013, 05:53 AM
Have you tried cycling through the screen options by pressing the 'Display" button?
Maybe that is stuck on the off position.
Cheers, Rob

BB from NYC
11th March 2013, 03:03 PM
Thanks for reply, Rob!

I did try the Display button at many points, and in various sequences of powering up and down, switching LVF-LCD, etc. The physical button seems to be operational (not stuck in place).

This is kind of a downer; my previous GH2, just a year younger, woke up bricked one morning and had to get some serious internals replaced under warranty. I love the GH series but am now hesitating about the GH3, given these problems.

hschnee
11th March 2013, 05:04 PM
Is it the same when playing back images? It's probably worth a quick check to see if this also only shows up in the EVF and not on the rear LCD. Either way it's likely a serious internal problem, but would be interesting to know nonetheless.

- Hal -

BB from NYC
11th March 2013, 06:50 PM
Hi Hal, the LCD is just as dead in playback.

Hey, I just realized something-- should the LVF work at all when the LCD screen is open? Isn't it one or the other?
On my other GH2 when I open the LCD the finder goes black, and when I close it the finder comes back on.

So the odd thing is the finder on the "bad" GH2 is on all the time. Is that a clue?

PatsGH2
11th March 2013, 09:19 PM
Actually on mine when I take my eye away from the LVF it turns off and the LCD turns on and vice versa. So yes, it is one or the other, but normally the LCD is on when the camera is away from the face.
It seems that you have been unlucky but it is very likely that when they repaired the camera the first time they messed up something to do with the display unit (loose cable maybe) which did not show up until now. In any case it sounds like the camera needs to make another trip back to the repair shop.
Best of luck,
Pat

BB from NYC
12th March 2013, 01:52 AM
Thanks all for comments, on to the repair adventure.

BB from NYC
9th April 2013, 05:17 AM
Follow-up report:

I finally got around to preparing the GH2 for a repair ship-out and when I turned it on today the LCD worked fine.

Peter H
9th April 2013, 09:47 AM
Typical! Good Luck with it. Peter H